WhatsApp divulga 6 bugs que permitem que invasores executem código remotamente

WhatsApp divulga 6 bugs que permitem que invasores executem código remotamenteO WhatsApp revelou 6 bugs de segurança por meio de seu site de aconselhamento de segurança dedicado. Todas as vulnerabilidades são divulgadas em um site de consultoria de segurança, com o objetivo de fornecer detalhes mais transparentes sobre vulnerabilidades para usuários e profissionais de segurança.
Assim, o WhatsApp diz:
Levamos a segurança de nossos usuários muito a sério e oferecemos proteção líder do setor para nossos usuários em todo o mundo. Nossa equipe de segurança no WhatsApp trabalha com especialistas em todo o mundo para ficar à frente de ameaças potenciais.

WhatsApp divulga 6 bugs

Antes de mais nada, os 6 bugs de segurança do WhatsApp são:

CVE-2020-1894: Um bug de estouro de gravação de pilha no WhatsApp Business para Android.
CVE-2020-1891: Um parâmetro controlado pelo usuário usado em videochamadas no WhatsApp para Android.
CVE-2020-1890: Um problema de validação de URL no WhatsApp para Android.
CVE-2020-1889: Problema de desvio de recurso de segurança em versões WhatsApp Desktop.
CVE-2020-1886: Um estouro de buffer no WhatsApp para Android.
CVE-2019-11928: Um problema de validação de entrada nas versões do WhatsApp Desktop.

WhatsApp divulga 6 bugs que permitem que invasores executem código remotamenteO WhatsApp revelou 6 bugs de segurança por meio de seu site de aconselhamento de segurança dedicado.
CVE-2020-1894: Afeta o WhatsApp para Android antes da v2.20.35, o WhatsApp Business para Android antes da v2.20.20, o WhatsApp para iPhone antes da v2.20.30 e o WhatsApp Business para iPhone antes da v2.20.30.
CVE-2020-1891: O bug afeta o WhatsApp para Android antes da v2.20.17, o WhatsApp Business para Android antes da v2.20.7, o WhatsApp para iPhone antes da v2.20.20 e o WhatsApp Business para iPhone antes da v2.20.20.
CVE-2020-1890: Afeta o WhatsApp para Android antes da v2.20.11 e o WhatsApp Business para Android antes da v2.20.2.
CVE-2020-1889: O bug afeta o WhatsApp Desktop antes da v0.3.4932.
CVE-2020-1886: Afeta o WhatsApp para Android antes da v2.20.11 e o WhatsApp Business para Android antes da v2.20.2.
CVE-2019-11928: Afeta as versões do WhatsApp Desktop anteriores à v0.3.4932.
Fonte: GBHackers
Facebook vai listar todos os problemas de segurança do WhatsApp em um novo site dedicado

Como ler mensagens excluídas no WhatsApp?

WhatsApp permitirá que os usuários definam papéis de parede diferentes para cada chat

FONTE: Blog SempreUpdate
(Excelente website de notícias! Recomendo!)