Milhões de sites WordPress sofrem ataques com bug de plug-in

Milhões de sites WordPress sofrem ataques com bug de plug-inEsta foi uma semana de risco para milhões de sites WordPress que foram alvo de ataques com um bug em um plug-in esta semana. Os dados são da empresa Defiant, responsável pelo firewall web Wordfence. O aumento repentino de ataques aconteceu depois que hackers descobriram e começaram a explorar uma vulnerabilidade de dia zero no “File Manager“. Este é um popular plugin WordPress instalado em mais de 700.000 sites.
O dia zero era uma vulnerabilidade de upload de arquivo não autenticado [1, 2]. Isso permitia a um invasor fazer upload de arquivos maliciosos em um site executando uma versão mais antiga do plugin File Manager.
Não está claro como os hackers descobriram o dia zero. No entanto, desde o início desta semana, eles começaram a sondar os sites onde este plugin pudesse estar.
Se eles encontrassem algo, explorariam o dia zero e carregariam um shell da web disfarçado em um arquivo de imagem no servidor da vítima. Os invasores acessariam o shell da web e assumiriam o site da vítima, prendendo-o dentro de um botnet.

Milhões de sites WordPress sofrem ataques com bug de plug-in

Milhões de sites WordPress sofrem ataques com bug de plug-in
“Os ataques contra essa vulnerabilidade aumentaram dramaticamente nos últimos dias”, disse Ram Gall, analista de ameaças da Defiant. Os ataques começaram lentos, mas se intensificaram ao longo da semana. Apenas na última sexta-feira, dia 4 de setembro, a Defiant registrou ataques contra 1 milhão de sites WordPress.

No total, Gall diz que a Defiant bloqueou ataques contra mais de 1,7 milhão de sites desde 1º de setembro, quando os ataques foram descobertos pela primeira vez.
O número de 1,7 milhão é mais da metade do total de sites WordPress usando o firewall da web Wordfence.  Gall acredita que o verdadeiro número de ataques é ainda maior. Isso porque o WordPress está presente em centenas de milhões de sites.

A boa notícia é que a equipe de desenvolvedores do File Manager criou e lançou um patch para o dia zero no mesmo dia em que soube dos ataques. Alguns proprietários de sites instalaram o patch, mas, como sempre, outros estão ficando para trás.
É essa lentidão na correção que recentemente levou a equipe de desenvolvedores do WordPress a adicionar um recurso de atualização automática para temas e plug-ins do WordPress. A partir do WordPress 5.5, lançado no mês passado, os proprietários de sites podem configurar plug-ins e temas para se atualizarem automaticamente sempre que uma nova versão é lançada. Assim, garantem que seus sites estejam sempre executando a versão mais recente de um tema ou plug-in e permaneçam protegidos de ataques.

FONTE: Blog SempreUpdate
Mais uma vez, agradecemos aos autores originais desta publicação.